
 

 

 

 

 

 

 

 

Upgrading Your Store from v6/v7 
A step-by step guide to successfully moving up to the new 
version. 
Covering: 

• Overview 

• Exporting data from v6/v7 

• Importing this data into v8 

• The upgrade process 

• Techniques for making your store look right 

• Techniques for starting with a 'clean' v8 design 

• Transferring your orders from your v6/v7 store into v8 

 

 

Note: This guide goes not cover upgrading from v4/v5. This is dealt with in a 
separate guide available from Actinic Software. 

 



Upgrading to Actinic v8  Upgrading Your Store from v6/v7 

Overview 
This guide goes through the process of upgrading your v6/v7 site to v8 using 
a snapshot. 

Tip: When you first install v8, it's a good idea to take time to familiarise 
yourself with the new features. There is an introduction to these features in 
the second half of this guide. 

The steps to upgrading your site to v8 are as follows: 

• Export a 'snapshot' of your current site design from v6/v7. 

• Import the snapshot into v8, when your data and design will be 
upgraded. 

• Review the upgrade changes made to your design by Actinic and make 
any necessary fixes. 

• Test the updated v8 design. 

• Suspend ordering on your current live store. 

• Transfer the latest orders into v8. 

• Put your site live with v8. 

 

Export Snapshot 
To export a snapshot from you v6/v7 site, go to 'File | Snapshot | Export 
Site'. 

 
Then follow the steps in the wizard to export an *.acd file to your computer.  

 
This file is your 'snapshot' which contains everything required to run your 
Actinic store. 
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Importing a Snapshot into v8 
Note: While you are importing your site into v8 and getting it working 
correctly, you can leave your current live store operational. You will not need 
to suspend ordering until later in the process. 

To import a snapshot into v8, go to 'File | Snapshot | Import Site'. You will 
then be taken through the 'Importing a Site' wizard. 

 
When you are given these three options, make sure you select all three 
boxes. If you select 'All Orders'- it will select all three automatically for you. 

At this point, your database will be updated to be compatible with v8.  

 
When that has completed, you can click 'OK'. 

If you are given an 'Update Files Path' button at the end of the snapshot 
import, this means that some of your products are using product images 
that are stored outside the Actinic 'site directory' (usually called 'Site1') on 
your PC. 

 
• If you have installed v8 on the same PC as v6/v7 then don't click the 

'Update Files Path' button. 

• If you have installed v8 on a different PC then you will need to click 
the 'Update Files Path' button. 

Then click 'Finish' to close the snapshot import.  

At this point, the 'Site Upgrade' will start. 
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The site upgrade works through all the design data in Actinic and converts it 
to be compatible with the new v8 design framework. 

• All your customised templates will be converted into 'layouts'. 

• All your custom properties will be converted into 'user-definable 
variables'. 

 

Warnings You May Encounter 
You may be shown this prompt: 

 
If this happens, check 'Design | Themes' in v6/v7 for the name of the theme 
that your design was originally based on. Enter it into the field here. 

You might also see this warning: 

 
This just means Actinic has found a few files as part of your design that it 
doesn't know what to do with – so it leaves them alone. 

You may also see this warning: 
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This means Actinic has overwritten any changes you made to 'Design | Text' 
– so you may need to check them and re-apply them. Details are in the log 
file mentioned.  

Once you the import has finished, you can start to look at your upgraded 
design and fix any problems. This is discussed in the next chapter. 

Alternatively, you could decide to go back to a set of clean v8 layouts, and 
then re-apply your design – this is discussed in the chapter called 'Starting 
Your Design From Scratch'. 
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Post-Upgrade Testing 
Once your site has been imported and upgraded, you will need to do some 
testing to ensure everything is working as you need it to. 

The first thing to do is a 'Coding Check'. This is an automatic test done by 
Actinic to ensure your design is working as expected. 

To perform this check, change to the 'Design' tab in Actinic and then go to 
'Design | Check Coding Errors'. 

 
To find out what an error is referring to, double-click on any error to go to 
the layout that has the problem. 

Note: If your error log looks like the one above, it is because your 'Overall 
Page Layout' contains <form>...</form> tags. These need to be removed. To 
select your overall page layout in the 'Design' tab, click in an empty part of 
your page design at the top or the bottom of your design. The layout you 
need to edit is called something like 'Act_Primary (Upgraded)'. 

Once you have found all the errors generated by the coding check, the next 
step is to click through the sections and brochure pages in the content tree 
and examine all your products etc. closely for any design issues. If anything 
looks strange, you can just click on it in the preview in the 'Design' tab and 
you will be taken to the layout that contains the problem. The layout code 
will be displayed in the panel underneath the preview.  

 

Testing The Store Online 
To test the operation of the store online, go to 'Web | Switch To Test Mode'. 
You can then go to 'Web | Refresh Website' to upload your store, and this 
will upload your store to a folder called 'test' within your online 'acatalog' 
folder. 

Note: Make sure you have some spare space on your web site as this will 
upload another copy of your entire store. 

Click the  button on the toolbar to see the site online. Place some test 
orders and see well how it functions.  

 

Editing Non-Section Pages 
If you find some problems on some pages other than the section pages, you 
can still edit these pages via the 'Design' tab. Simply select the page you 
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need to tweak in the 'Select Page Type' drop down list at the top left of the 
'Design' tab. 

 
 

Where Can I Change The Selected Layouts? 
If you just want to take a look at a default v8 product layout or overall layout 
and compare them to your upgraded ones, you can select alternative layouts 
in the following places: 

• Product Layouts – You can change the default product layout in the 
'Product Layout' field in 'Settings | Site Options | Layout' (under the 
'Product' sub-heading). You can then override this setting within the 
'Layout' tab of a product, or the 'Layout' tab of a section. You can also 
view the code of all the different product layouts (including your 
upgraded ones) within the 'library' by going to 'Design | Library | 
Layouts' and opening the 'Products' group. 

• Section Link Layouts – You can change the default section link 
layout in the 'Section Link Layout' field in 'Settings | Site Options | 
Layout' (under the 'Section' sub-heading). You can then override this 
layout within the 'Layout' tab of a section. You can also view the code 
of all the different section link layouts (including your upgraded ones) 
within the 'library' by going to 'Design | Library | Layouts' and 
opening the 'Section Links' group. 

• Overall Page Layouts (aka Primary templates) – The default overall 
page layout for the store is set in the 'Overall Page Layout' field in 
'Settings | Site Options | Layouts'. You can also change the overall 
page layout for the checkout, view cart page and login page here. The 
overall page layout can be overridden for an individual section in the 
'Layout' tab of a section. Brochure overall layouts are set within the 
'Brochure Page Layout' field in 'Settings | Site Options | Layout', and 
can be overridden within the 'Layout' tab of a brochure page. All the 
different overall page layouts (including your upgraded ones) can be 
viewed within the 'library' by going to 'Design | Library | Layouts' and 
opening the 'Web Page Outer Layout' group. 

• Fragment Layouts – You can change the default fragment layout in 
the 'Fragment Layout' field in 'Settings | Site Options | Layout' (under 
the 'Fragment' sub-heading). You can then override this setting within 
the 'Layout' tab of a fragment, or the 'Layout' tab of a brochure page 
or section. You can also view the code of all the different fragment 
layouts (including your upgraded ones) within the 'library' by going to 
'Design | Library | Layouts' and opening the 'Fragments' group. 
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Starting a Design From Scratch 
Want to start your design from scratch with a default set of Actinic v8 
layouts? No problem. 

Here is what to do: 

First you need to change the store theme to a default Actinic v8 theme. 

1. Go to 'Design | Themes' and select a new design from the 'Themes' 
list. 

2. Click 'OK'. 

Note: Unlike in v7, this only changes the 'overall page layout' for your store – 
it will not affect any other layouts. 

The next thing to do is reset the Actinic Stylesheet layout to a default one, 
rather than an upgraded one. To do this: 

3. Go to 'Design | Library | Layouts'. 

4. Open the 'Web Page Outer Layouts' group. 

5. Locate the 'Actinic Stylesheet' layout. 

6. Right-click on it and select 'Revert to Factory Settings'. 

This will reset the stylesheet back to the Actinic default. 

Next you need to change the product layouts, section link layouts etc to use 
default v8 layouts rather than the upgraded ones. To do this: 

7. Go to the locations described in the 'Where Can I Change The Selected 
Layouts?' section in the previous chapter. 

8. Make sure that none of the layout fields in the 'Layout' tab are using 
layouts that have '(Upgraded)' in their names. 

You may also need to check the 'Layout' tabs of your 
sections/products/fragments etc. to make sure none of them have an 
'(Upgraded)' layout selected. 

This should then get you up and running with a default v8 layout 

If you do find any other coding elements that look strange, try the following: 

1. Click on the wrong looking code in the 'Design' tab. 

2. Make a mental note of the name of the layout that appears in the title 
bar of the layout code panel in the 'Design' tab.  

You are now going to reset this layout via the library. 

3. Go to 'Design | Library Layouts'.  

4. Right-click anywhere within the library and select 'Find'. 
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5. Enter the name of the layout you want to find and click 'Find Next 

Item'. 

6. When you have found the layout in the library, right-click on it and 
select 'Revert To Factory Settings'. 

 
This will then restore the layout back to the v8 original. 

Note: In order to highlight any layouts that are different to the v8 original, 
select the 'Highlight Customised Layouts With (*)' checkbox at the bottom of 
the 'Layouts' tab in the 'Library'. All layouts that contain code upgraded from 
v6/v7 will be marked with a (*). 
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Moving Your Live Store Into v8 
Here is how to bring all your latest orders into v8, but still retain all your 
design changes that you have made. 

1. Take a snapshot from v8 by going to 'File | Snapshot | Export Site'. 
Store this somewhere safe. 

2. Now go back to your v6/v7 store. 

3. Go to 'Business Settings | Ordering'. 

4. Under 'Online Ordering' select 'Suspended'. This will remove all the 
add to cart buttons from Actinic. 

5. Upload the store. 

6. Now wait 30 mins and then retrieve the latest orders. 

This will ensure that you will not lose any orders while the transfer is taking 
place. 

7. Once you are satisfied there are no more orders on the online store, 
take a snapshot from your v6/v7 store. 

Make sure you do not save over the top of the snapshot you have taken from 
v8! 

8. Import this new snapshot from v6/v7 into v8. This will go through the 
upgrade process as described earlier in this guide. 

9. When you get to this screen: 

 
...make sure you select 'All Orders', 

10. Complete the import. 

Don't worry about losing all the design changes you have made in v8 - these 
are safe in your v8 snapshot. 

11. Once the database upgrade has completed, and the site upgrade has 
finished, check the orders are all intact in the 'Orders' tab in v8. 

You can now import your updated v8 content and design back into v8 
(leaving the orders alone). 

12. Go to 'File | Sites | Import Site' and import your v8 snapshot you 
saved in step 1. 
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13. When you get to this screen: 

 
...make sure 'All Orders' is NOT selected, but 'All Contents' is selected. 

14. Complete the import. 

This will import all the content and updated design data – but leave your 
orders intact. 

15. Finally, go to 'Web | Switch To Production Mode' to change the store 
back to production mode. Also, go to 'Business Settings | Ordering' 
and ensure that 'Suspended' is not selected. 

16. You can now go to 'Web | Refresh Website' to put your store live with 
v8. 

 

Congratulations! You have now successfully upgraded your store to v8. 
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New Features 
The new features to check out in v8 
 

Covering: 

• Menus and panels 

• Password protection 

• Order processing enhancements 

• Best sellers lists and new products lists 

• Related items lists and also bought lists 

• Mailing lists 

• Themes and colours 

• Choosing alternative layouts 
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Menus & Panels 
Settings 
Business Settings, Search Settings and a few other settings can be found in 
the new 'Settings' menu. 

 
The 'Settings' menu also includes a new 'Site Options' feature, which is 
where you can set the default value for lots of different settings within 
Actinic.  

Note: Within the 'Design' menu you will see 'Design Options', which is a cut 
down version of the old Design Options control in v6 and v7. Most of the 
controls that were in Design Options in v7 are now in Site Options. 

Operations 
All the order processing functionality can now be accessed via the 
'Operations' menu. 

 
This includes all customer account, email and stock monitoring 
functionality. 

Marketing 
Also, there is a new 'Marketing' menu for accessing discounting, customer 
groups and the new promotional list features (such as best sellers lists and 
also bought lists). 
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Window 
The most useful option within the 'Window' menu is the 'Restore Initial View 
Layout' option. Use this to put the panels back to how they were, after you 
have re-organised them. 

To move a panel, click on the title bar and move it around you can: 

• Undock it 

• Dock it to a different part of the screen 

• Lay it over another panel to create tabs 

 
• Roll it up so it only appears when you click on it 

 
Design 
Access the themes, the library and Design Options. You can also check 
coding errors from this menu.  
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Password Protection 
In 'Settings | Business Settings | Options' there is a new option called 
'Enable Logon and Card Encryption'. 

 
Selecting this option means that users will have to enter a password to 
access the Actinic application.  

Note: The default password is Administrator. 

If you then go to 'Housekeeping | Encrypt Existing Credit Card Data' it will 
mean that all the credit card information in Actinic can only be accessed via 
Actinic – and people will no longer be able to view this information in clear 
text in the Access database. 
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Order Processing Enhancements 
One-Click Order Completion 
Previously, Actinic's 'One-Click Order Processing' feature was only available 
in 'Multi-User' versions of Actinic. With v8, this feature is included with all 
versions of Actinic. 

Using this feature it is possible to pre-configure the things you want Actinic 
to do to each order, and then simply 'Complete' the orders with a single 
click. This is configured in Business Settings | Order Processing' 

 
You can now right-click on any order in the 'Pending' tab and select 
'Complete Order'. Or highlight an order and click the 'Complete' button.  

 
The order should move to the 'Completed' tab. 

 

Editing Offline Prices 
In 'Settings | Business Settings | Order Processing' there is an option 
labelled 'Allow Unit Price Override'. 

 
Selecting this option means that you can override the price of a product 
while you are creating an offline order, or editing an order offline. This is 
useful if you want to give the customer money off their order while you are 
taking the order. 

 

Bar Codes 
Also in 'Business Settings | Order Processing', Actinic Business users have 
an area called 'Bar Codes on Reports'. This allows you to print key 

 - 16 - 



Upgrading to Actinic v8  New Features 

information on the reports as bar codes for quick transfer into other 
systems. 

 

 
 

Integrated Labels 
Finally in 'Business Settings | Order Processing' there is an area called 
'Integrated Address Labels'. 

 
This enables you to generated invoices that are pre-formatted to print onto 
sheets of paper that have peel-off labels. 
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Best Sellers and New Products 
Best Seller Lists and New Products Lists are lists of products that can 
appear on every page (or just on specific pages) to promote certain products 
to your customers. 

• Best sellers lists work out the best selling products from the orders 
that have been received, and display them as a list in the store. The 
best selling items in your store are the ones that most people will 
come to your site to buy, so by displaying them prominently in your 
store you will help customers find them more quickly, which will turn 
into more new orders. 

• New products lists are made up of the newest items that have been 
added to the store. It is important to keep displaying your newest 
product lines as this keeps your store content current and up to date 
and hopefully gives customers a reason to keep coming back to your 
store.  

By default in the example Actinic store there is a new products list in the 
sidebar of every page, and also on the brochure home page.  

You can setup these lists from the 'Marketing' tab. 

 
 
More Information – Fixing Items In the List 
If you go to the grid at the bottom of 'Marketing | Best Sellers' or 'Marketing 
| New Products Listing' you can click on any item in the list and use the 
drop-down list to change it to a different item. 

Using this method it is possible to manually configure the list if there certain 
products you want to promote, or certain products you don't want to 
promote. 

You can also click the 'Lock' checkbox to fix that product in the list and let 
all the other products auto-generate around it 
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Related Item Lists and Also Bought Lists 
As well as the best seller lists and the new products lists, it is also possible 
to display lists of products underneath each product in the store. Again, 
these are set up from the 'Marketing' tab. There are two types of these lists: 

• Related Product lists – where you can configure a list of other 
products that are related to a product, and then display them on the 
online store with a link to the related product. 

• Also Bought lists – (Actinic Business/Designer only) – these are 
automatically worked out by Actinic. Actinic can take a product in 
your store, then look at all the orders that include that product, and 
then look at what else the customers ordered. These then become a 
'customers who bought this also bought…' list underneath each 
product. 

Once you have enabled these lists, you can configure them in the 'Marketing' 
tabs of the products in your store. 

 

More Information – Lists in the Shopping Cart 
Once you enable either related item lists or also bought lists you will see a 
list appearing in the online shopping cart underneath the grid of products. 
These lists show the related products and also bought products for the 
product that is currently in the shopping cart. If there is more than one 
product in the shopping cart, then Actinic will merge all the related products 
and also bought products into a single list. 
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Mailing Lists 
Actinic gives you the ability to easily extract your customers' contact details 
out of Actinic. This information can then be imported into emailing programs 
like Microsoft Outlook or GroupMail in order for you to mail your customers 
with promotional material. 

This feature can be found at 'Marketing | Mailing Lists'.  

 
All versions of Actinic allow you to filter your customers' contact details 
based on when they placed orders, and what the status of the order is. 
Actinic Business/Designer customers can go further and filter the list based 
on what products were ordered, where the customer is located and how large 
the order was. With Actinic Business/Designer, you can also print mailing 
list information onto labels and envelopes. 
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Themes and Colours 
The new themes are: 

• Executive – Uses CSS for layout and navigation item formatting 
(though there are a couple of tables used to solve cross-browser 
issues) 

• Technical – Uses CSS for layout and navigation item formatting 
(though there are a couple of tables used to solve cross-browser 
issues) 

• Contemporary – Uses CSS for layout and some navigation items 

• Clean Layout Using CSS – Pure CSS positioning 

 

Point-And-Click Text Formatting 
If you look at the top of the Details panel you will see there is a toolbar for 
text formatting. 

 
You can highlight text in the descriptions of your products and sections, and 
use the formatting controls here to change the appearance of it. 

Furthermore, by clicking on text in the 'Design' tab, you can change the 
appearance of 'variables' in the design e.g. change the appearance of ALL the 
product names in the store in one go. 
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Design Overhaul 
A Introduction To The Underlying Philosophy Behind The 
New Design Features 
 

Covering: 

• Background to the design overhaul 

• Fundamental building blocks of design in Actinic 

• The Design tab 

• Variables, layout selectors and conditions 
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Why We Changed Everything 
The template system within Actinic v6/v7 was very similar to how it was in 
v2 – which is now ten years old! 

For v8 we took a completely fresh look at what are the requirements for 
design and came up with the following. 

• You need little fragments of HTML to get pulled together to build the 
pages. These are called 'layouts'. 

• Within these layouts you have 'variables' that are substituted for data 
in the database. 

• You need rules within a layout to control what code is visible when 
(e.g. only showing quantity fields for certain shopping modes). These 
rules are defined as 'conditions' and put into the layouts via 'blocks'. 

• Merchants need to be able to select layouts via the user interface. So 
you need a placeholder called a 'layout selector' that inserts the 
selected layout into the design. 

• Sometimes you get lists of products, lists of sections etc. You need to 
be able to control how these 'lists' work – how many columns etc. 

This is the architecture of design in Actinic. Everything you see springs from 
these five basic concepts. To create the design data in v8 we threw away all 
the templates, and built the designs with those five concepts.  

Now, once you master those five concepts you can control the existing 
layouts and also build in your own custom design elements. 

 

For a full understanding of how design works in v8, check out the v8 Getting 
Started Guide in 'Help | Starter Guide'. This will go through variables, lists 
etc. and give you some exercises to help you become familiar with the new 
concepts. 
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The Design Tab 
All the new layout elements are controlled from the 'Design' tab/ 

The most important feature of the Design tab is the Interactive Preview. 
You can click on any element in the preview to edit it. 

Anything you select in the preview screen will appear in the Layout Code 
panel. You can then make changes here to see the effect it has on the 
preview. 

 
You can change section/product by clicking on the Content Tree to the 
right. 

The Select Page Type drop down list on the 'Design' tab can be used to edit 
pages other than ones in the content tree. 

You can view the details of anything selected in the content tree by clicking 
on the Details tab to view the Details panel. 

Finally, it is also possible to view the Design Tree by clicking the tab at the 
bottom right. This shows you the structure of the layouts in the current 
page. 
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Layout Code 
Within the layout code you will see the following: 

 
(in blue) 

A variable. Will be substituted for 
some data in the database.  

 

 
(in purple) 

A layout selector. Shows where a 
layout is being inserted within the 
current layout. Right-click and select 
'Navigate To' to view the inserted 
layout. 

 

A conditional block. Double-click on 
the opening block tag to view the 
condition 

 

When you look at the layout code normally, you are looking at a 'basic' view, 
where variables, layout selectors etc. are compacted in an 'easy-to-view' 
style. 
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